Игорь Олемской — практические заметки по системному администрированию Linux CentOS

Установка актуальных версий PHP / MySQL на CentOS 5

6 комментариев

В стандартной комплектации CentOS 5 идут достаточно устаревшие версии PHP (5.1.6) и MySQL (5.0.45), которых, к сожалению, все чаще не достаточно для работы современных веб-приложений.

Ниже описано, как установить актуальные версии из yum-репозитория «remi».

Установка epel и remi

rpm -Uvh http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-5.rpm

Если php и mysql уже установлены, необходимо запустить

yum --enablerepo=remi update php\* mysql\*

Если mysql-server еще не установлен

yum --enablerepo=remi install mysql-server

Установка php, php-cli, php-ускорителя «eaccelerator» и частоиспользуемых php-библиотек

yum --enablerepo=remi install php php-cli php-eaccelerator php-mysql php-mbstring php-gd

23.05.2009

Написал Игорь Олемской

6 комментариев к 'Установка актуальных версий PHP / MySQL на CentOS 5'

Подписаться на комментарии RSS или Trackback к 'Установка актуальных версий PHP / MySQL на CentOS 5'.

  1. Привет!

    при сустановки по инструкции выходя ошибки

    Transaction Check Error:

    file /usr/share/info/mysql.info.gz from install of mysql-5.1.41-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.77-3.el5.i386

    и так далее в таком духе

    Error Summary

    -------------

    mailfox

    13.12.2009 в 10:03

  2. Попробуйте удалить mysql командой:

    yum remove mysql\*

    а потом заново установить:

    yum --enablerepo=remi install mysql-server

  3. с празничком

    online

    01.01.2010 в 7:59

  4. спасибо! все отлично установилось!

    sergant11

    13.01.2010 в 2:00

  5. thanks

    freem

    25.06.2010 в 4:07

  6. было бы неплохо расписать самостоятельную сборку с наиболее интересными параметрами

    _kt

    27.12.2010 в 11:25

Комментировать